Автор Тема: Китайская "автомагнитола" "SONY" выезжает экран и всё.  (Прочитано 1196 раз)

стопыч

  • Пользователь
  • ***
  • Сообщений: 24
 Есть китайское чудо с выезжающим и отгибающимся вверх экраном. В моем случае надпись на нем SONY. Больш никаких опознавательных...
  Проц VIBRATO ES6168FAF флешь SST39VF080, eeprom ATMEL 24C04, тюнер BZ8M06A, ATMEGA32L8A. Вот примерно состав. Плата майн узеньким пистолетом сделана. Написано на ней CZLCD_MAIN4A 2007.05.11. Экран выезжает и не светится. Подсветка узкого дисплея светит пока выедет экран и тухнет. Ни диски ни тюнер, только можно еще раз передернуть кнопкой включения - экран заезжает. И всё!!!
 Я так понимаю шить надо флешь SST39? У меня адаптер в прогере TSOP48, а она TSOP40. Какой прогой и к каким точкам, чтоб считать и прошить через проц? А мож это 24С04 надо шить?

стопыч

  • Пользователь
  • ***
  • Сообщений: 24
 Оказывается у меня есть чем TSOP40 шить. Адаптер у меня для трех сразу TSOPов (32_40_48). Осталось дамп от флехи для этой магнитолы найти. Прошу помощи в поиске прошивки. Ночью будет время, считаю из: флехи, епром, АТМЕГИ и выложу.

semvictor

  • Пользователь
  • ***
  • Сообщений: 41
А шлейф?

Dumon

  • Новичок
  • **
  • Сообщений: 5
Да не в прошивке тут дело , шлейф прозвони.

стопыч

  • Пользователь
  • ***
  • Сообщений: 24
 Делать стало нечего...  Попалась на глаза эта магнитола.  Шлейфы проверены (широкий и узкий), те что от выезэающей платы к майну. Шлейфы исправны. Флешь навсяк прочитана прогером. Атмега тож прочитана. Концевики на майне проверены, исправны.  Сигналы с концевиков идут на Атмегу. Цепи от концевиков до атмеги прозвонил. Чё там пара резиков то.
  Не, не шлейфы это. После выезда панели, что должно происходить? Должен засветиться экран.  Нима!  Есть у кого прошивка от флеши от этого чуда?

стопыч

  • Пользователь
  • ***
  • Сообщений: 24
 нашел почерневший резистор. Измерил - 10ом, вродь так и должно, судя по оставшимся надписям на нём. Ничего не нахожу битого.

стопыч

  • Пользователь
  • ***
  • Сообщений: 24
Да и этот резистор вообще можно выкинуть. А раз почернел, знач сзади в разъем чего то пытались воткнуть. А вот с каким пином его коротнули? Ну, был бы стабилизатор какой в коротыше или транзистор... Нет, не пробито ничего. Слаживать и включать. Но мерять страшно неудобно тогда. Ну как-то изъе вернусь. Вот флешь впаивать надо на место. А вдруг прошива калеченая в ней. Есть у кого, чтоб сравнить? я с флеши считал.

стопыч

  • Пользователь
  • ***
  • Сообщений: 24
 Считал еще раз с флешки SST39VF080.   Что-то оно не очень на прошивку похоже.  Разве такое может быть (см вложение)?

стопыч

  • Пользователь
  • ***
  • Сообщений: 24
так и есть, это не прошивка, а хрень собачья! Подскажите, какую туда лить? Неужели   никто не считал с подобной? они разными марками "назывались", и Сони, и Кенвуд, и Джи Ви Си.

seregatv

  • ПАЛАЧ
  • Старший модератор
  • Специалист
  • ****
  • Сообщений: 4555
  • Сергей
К модеру раздела в личку постучи, может у него есть.
Грамотно отвешенная оплеуха очень сильно ускоряет процесс познания истины. http://ledtvmaster.by

Aristak

  • Модератор
  • Специалист
  • ***
  • Сообщений: 1446
стопыч Вы наверное потеряли вашу тему а я нет   :biggrin:  вот ваша тема внизу http://televid-sib.ru/index.php?topic=37029.40
стопыч Не надо ничего шить я бы сперва проверил бы питания 5v 3,3v  и т.д... ну и шлейф а вы проверили ? нет  :nea:
я вам ответил а вы молчали


стопыч

  • Пользователь
  • ***
  • Сообщений: 24
Извиняюсь.  Отложил тогда, думал ненадолго...
   Кажется я понял в чем бида...  Нижняя плата адаптера не та наверное. На ней TSOP48/SOP44. А  надо бы TSOP40A. у меня её нет пока. Наверное пока отложу до завладения нижней платой адаптера.
   Поэтому видать и нечтение?

стопыч

  • Пользователь
  • ***
  • Сообщений: 24
вот он

стопыч

  • Пользователь
  • ***
  • Сообщений: 24
впаял флешь на место. Включил без дисковода и без блока управл моторчиками выдвижения.  Светится, не переставая, подсветка дислея малого на передней панели и краным кнопка PWR. U4 (см вложение) вход_ +12в.  выход_ +0,4в. На 4-й ноге U4 _ +11,4в. Мож потому, что не всё подсоединено? Питание Атмеги 4,7в есть. На кнопки реакции нет. На концевики на майне нажимал - ноль реакции.

стопыч

  • Пользователь
  • ***
  • Сообщений: 24
транзистор U4 (FDS9435A) выпаивал и проверял. Открывается и закрывается. С 4-той ноги U4 через 100 кОм к плюс 12в и больше никуда нет дорожки. Как так? На кой он там вообще? Я так понял он открывается сразу при подаче питания на разъем магнитолы?

стопыч

  • Пользователь
  • ***
  • Сообщений: 24
Не, не сразу! Он P-ch!!! Таки вызвонил откуда упр-ся Pin4 (U4)! Атмега Pin20, R177/4k7, QB1 (n-p-n), R10/30k, U4 Pin4. Все эти детальки живы. Pin20 Атмеги не пробит. Таки пришел к Атмеге. Тааак, мож она молчит (генерация)? Полез за ослом...

стопыч

  • Пользователь
  • ***
  • Сообщений: 24
  Генерация на кварце Атмеги Pin7, Pin8 есть. Предохранители на плате экрана живы все.  Первым делом должен открыться U4. Этого не происходит. Надо бы понять, как сделана цепь от кнопки включения.  *SCRATCH*
  Открывал U4 принудительно, замыкав коллектор QB1 на GND. Загорается подсветка всех кнопок. Подсветка большого экрана не светилась при этом.
  На Атмеге есть еще один кварц (наверное часовой), на нем генерации нет. Но мож должны быть выполнены некоторые условия, чтоб генерация на этом втором кварце появилась? Или генерить на нем должно и при наличии питания на Атмеге?

стопыч

  • Пользователь
  • ***
  • Сообщений: 24
 :bp:  Наконец то оно включилось!!! Надо было таки шить! Атмегу!!! Скок хошь могбы шлейфы проверять и ключи  *DONT_KNOW*
 Ща сберу воедино на проверку всего остального. Хоч какая то польза от самоизоляции!   *YES*

стопыч

  • Пользователь
  • ***
  • Сообщений: 24
 И выдвижной экран пашет!  *YES*

стопыч

  • Пользователь
  • ***
  • Сообщений: 24
 А, блин, совсем забыл, там нет унча, выпаял давно и куда то задевал. Даж не помню какой там был из тда73хх?